红牛2008 / 主图公式 / 通达信三浪起点主图公式

0 0

   

通达信三浪起点主图公式

2017-04-22  红牛2008

DRAWGBK(O>C,RGB(0,50,50),RGB(66,0,0),0,''01'',0);
N:=13;DO:=150612;DA:=150826;DB:=151117;DC:=160108;
{黄金分割}
高:IF (HIGH>PEAK(1,N,1),HHV(HIGH,N),PEAK(1,N,1))LINETHICK2,COLORBLUE;{最高价}
低:IF (LOW<TROUGH(2,N,1),LLV(LOW,N),TROUGH(2,N,1))LINETHICK2,COLORMAGENTA;{最低价}
F0.191:(高-低)*0.191+低,DOTLINE,COLORMAGENTA;
F0.382:(高-低)*0.382+低,DOTLINE,COLORCYAN;
F0.500:(高-低)*0.500+低,DOTLINE,COLORWHITE;
F0.618:(高-低)*0.618+低,DOTLINE,COLORCYAN;
F0.809:(高-低)*0.809+低,DOTLINE,COLORYELLOW;
{三角背景}
趋势下:DRAWLINE(H=HHV(H,N),H,L=LLV(L,N),L,0)LINETHICK2,COLORGREEN;  
SX:=REF(趋势下,1)<趋势下;
SS:=DRAWLINE(SX,趋势下,REF(SX,1),REF(趋势下,1),1);
DRAWBAND(SS,RGB(0,0,160),趋势下,RGB(0,0,0));
趋势上:DRAWLINE(L=LLV(L,N),L,H=HHV(H,N),H,0)LINETHICK2,COLORMAGENTA;
JX:=REF(趋势上,1)>趋势上;
JJ:=DRAWLINE(JX,趋势上,REF(JX,1),REF(趋势上,1),1);
DRAWBAND(JJ,RGB(0,0,0),趋势上,RGB(180,0,180));
DRAWKLINE(HIGH,OPEN,LOW,CLOSE) ;
{大资金流向}
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
大资金流向:(超B+大B)-(超S+大S)COLORYELLOW,NODRAW;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE) ;
STICKLINE(大资金流向<0,O,C,2,0),COLORFF3300;
STICKLINE(大资金流向<0,O,C,1.2,0),COLORFF6600;
STICKLINE(大资金流向<0,O,C,0.5,0),COLORFF9900;
STICKLINE(大资金流向>0,O,C,2,0),COLOR0066FF;
STICKLINE(大资金流向>0,O,C,1.2,0),COLOR099FFF;
STICKLINE(大资金流向>0,O,C,0.5,0),COLOR00FFFF;
TL:=1000000+DA;
TH:=1000000+DB;
TC:=1000000+DC;
TO:=1000000+DO;
AL:=IF(REFDATE(CLOSE,TL)>REFDATE(CLOSE,TH),REFDATE(HIGH,TL),REFDATE(LOW,TL));
BH:=IF(REFDATE(CLOSE,TL)>REFDATE(CLOSE,TH),REFDATE(LOW,TH),REFDATE(HIGH,TH));
CZF:=IF(REFDATE(CLOSE,TL)>REFDATE(CLOSE,TH),REFDATE(HIGH,TC),REFDATE(LOW,TC));
DJB:=IF(REFDATE(CLOSE,TL)>REFDATE(CLOSE,TH),REFDATE(LOW,TO),REFDATE(HIGH,TO));
OP:=BH-AL+CZF;
COP:=0.618*(BH-AL)+CZF;
XOP:=IF((1.618*(BH-AL)+CZF)<0,OP,1.618*(BH-AL)+CZF);
TODAY:=DATE;
STICKLINE(DATE=TC,CZF,XOP,0,-1),COLORYELLOW;
DRAWLINE(DATE=TC,COP,DATE=TODAY,COP,1),DOTLINE,COLORYELLOW;
DRAWLINE(DATE=TC,OP,DATE=TODAY,OP,1),DOTLINE,COLORYELLOW;
DRAWLINE(DATE=TC,XOP,DATE=TODAY,XOP,1),DOTLINE,COLORYELLOW;
DRAWTEXT(DATE=TC,COP*1.003,''(COP=0.618)''),COLORYELLOW;
DRAWTEXT(DATE=TC,OP*1.003,''(OP=1.000)''),COLORYELLOW;
DRAWTEXT(DATE=TC,XOP*1.003,''(XOP=1.618)''),COLORYELLOW;
DRAWNUMBER(DATE=TC,COP,COP),COLORYELLOW;
DRAWNUMBER(DATE=TC,OP,OP),COLORYELLOW;
DRAWNUMBER(DATE=TC,XOP,XOP),COLORYELLOW;
DRAWLINE(DATE=TO,DJB,DATE=TL,AL,0)CIRCLEDOT,COLORGREEN;
DRAWLINE(DATE=TL,AL,DATE=TH,BH,0)LINETHICK2,COLORYELLOW;
DRAWLINE(DATE=TH,BH,DATE=TC,CZF,0)LINETHICK2,COLORCYAN;
 {www.guhai.com.cn}
{区间涨跌} 
↑:=TROUGHBARS(2,N,1);
↓:=PEAKBARS(1,N,1);
涨%:=IF(↑<↓,(C/低-1)*100,REF((C/低-1)*100,↓));
跌%:=IF(↓<↑,(C/高-1)*100,REF((C/高-1)*100,↑));
DRAWNUMBER(↑=0,低*0.99,ABS(高-低)),COLORGREEN;
DRAWNUMBER(↓=0,高*1.02,ABS(高-低)),COLORRED;
ZHSJ:=IF(↓<↑,BACKSET(ISLASTBAR,↓),IF(↑<↓,BACKSET(ISLASTBAR,↑),0));
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),高*1.004,''本      高''),COLORGREEN;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),低*1.004,''本      低''),COLORRED;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),F0.191*1.003,''80.9%''),COLORYELLOW;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),F0.382*1.003,''61.8%''),COLORCYAN;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),F0.500*1.003,''50.0%''),COLORWHITE;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),F0.618*1.003,''38.2%''),COLORGREEN;
DRAWTEXT(↓<↑ AND CROSS(ZHSJ,0.1),F0.809*1.003,''19.1%''),COLORRED;
DRAWNUMBER(↓<↑ AND CROSS(ZHSJ,0.1),高,高)COLORGREEN;
DRAWNUMBER(↓<↑ AND CROSS(ZHSJ,0.1),F0.191,F0.191)COLORYELLOW;
DRAWNUMBER(↓<↑ AND CROSS(ZHSJ,0.1),F0.382,F0.382)COLORCYAN;
DRAWNUMBER(↓<↑ AND CROSS(ZHSJ,0.1),F0.500,F0.500)COLORGREEN;
DRAWNUMBER(↓<↑ AND CROSS(ZHSJ,0.1),F0.618,F0.618)COLORCYAN;
DRAWNUMBER(↓<↑ AND CROSS(ZHSJ,0.1),F0.809,F0.809)COLORMAGENTA;
DRAWNUMBER(↓<↑ AND CROSS(ZHSJ,0.1),低,低)COLORRED;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),高*1.003,''前      高''),COLORGREEN;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),低*1.003,''前      低''),COLORRED;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),F0.191*1.003,''19.1%''),COLORRED;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),F0.382*1.003,''38.2%''),COLORGREEN;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),F0.500*1.003,''50.0%''),COLORWHITE;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),F0.618*1.003,''61.8%''),COLORCYAN;
DRAWTEXT(↓>↑ AND CROSS(ZHSJ,0.1),F0.809*1.003,''80.9%''),COLORYELLOW;
DRAWNUMBER(↓>↑ AND CROSS(ZHSJ,0.1),高,高)COLORGREEN;
DRAWNUMBER(↓>↑ AND CROSS(ZHSJ,0.1),F0.809,F0.809)COLORYELLOW;
DRAWNUMBER(↓>↑ AND CROSS(ZHSJ,0.1),F0.618,F0.618)COLORCYAN;
DRAWNUMBER(↓>↑ AND CROSS(ZHSJ,0.1),F0.500,F0.500)COLORGREEN;
DRAWNUMBER(↓>↑ AND CROSS(ZHSJ,0.1),F0.382,F0.382)COLORCYAN;
DRAWNUMBER(↓>↑ AND CROSS(ZHSJ,0.1),F0.191,F0.191)COLORMAGENTA;
DRAWNUMBER(↓>↑ AND CROSS(ZHSJ,0.1),低,低)COLORRED;
 

 

通达信这里是第三浪的起点么?主图公式

    本站是提供个人知识管理的网络存储空间,所有内容均由用户发布,不代表本站观点。如发现有害或侵权内容,请点击这里快3线公交车路线查询或 拨打24小时举报电话:4000070609 与我们联系。

    猜你喜欢

    0条评论

    发表

    请遵守用户 评论公约

    类似文章
    喜欢该文的人也喜欢 更多